"Welcome to Nginx" landing page issue  

Page 1 / 2 Next
  RSS

laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
08/07/2018 10:05 pm  

I've completed all the steps found on this page  https://vpsfix.com/4937/install-virtualmin-nginx-php-mysql-ubuntu/. But when I go to sendy.mydomain.com it shows a "Welcome to Nginx" page. Alternatively, when I go to sendy.mydomain.com:10000 it is a blank page. Is there something on top on what I've done to that I need to do?


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
08/07/2018 10:49 pm  

Did you add your domain to Virtualmin? And are you using Cloudflare or any kind of proxy?

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
08/07/2018 11:19 pm  

I have set up an AWS server running ubuntu 16.04, this occurred when setting up virtualmin. So I am unable to login to Virtualmin to set up my domain. My process so far: Created AWS server (ubuntu 16.04) I've associated an Elastic IP to the server (set up my DNS record accordingly) , updated ubuntu on the server, configured ubuntu host files for Virtualmin.  After I installed Virtualmin on my server I run into the "welcome to nginx" issue on my chosen sub-domain. 


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
08/07/2018 11:31 pm  

It's normal to see the default nginx page if you haven't add a domain in Virtualmin. In fact it's a good thing. Shows nginx is installed and working.

Setting up Virtualmin on AWS has few extra steps. You need to open port 10000 on your security group. I think you don't have it open. This is why you're not able to open Virtualmin. Virtualmin listen on port 10000 and your security group may be blocking it.

And after that make sure to enable root login and password login on your ec2 instance.

 

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 12:12 am  

I have opened port 10000 on a custom TCP rule with the correct source, I've also enabled root login and password according to those instructions beforehand, as you instruct in that link. 


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
09/07/2018 12:26 am  

Okay. Please run,

sudo service webmin status

and see if Virtulamin is running.

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 12:36 am  

under active : Active (running)

perhaps of interest:

systemd[1]: Starting LSB: web-based adminis

Jul 08 05:50:01 sendy.mydomain.com perl[1403]: pam_unix(webmin:auth): authenti

Jul 08 05:50:03 sendy.mydomain.com webmin[1403]: Webmin starting

Jul 08 05:50:04 sendy.mydomain.com systemd[1]: Started LSB: web-based administ

lines 1-15/15 (END)


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
09/07/2018 12:41 am  

What's the output of,

netstat -a | grep webmin

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 12:50 am  

tcp        0      0 *:webmin                *:*                     LISTEN     

tcp6       0      0 [::]:webmin             [::]:*                  LISTEN 


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
09/07/2018 1:00 am  

That looks fine. Can you give me a screenshot of your EC2 security group. Ideally a one with all inbound rules visible.

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 1:14 am  

Here you go.


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
09/07/2018 1:22 am  

That looks fine too. See if ufw is active. 

sudo service ufw status

If it's not active, try opening Virtualmin with IP address instead of your subdomain. See if it works.

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 1:26 am  

It is active. The IP address brings up the "Welcome to Nginx" Page also, myip:10000 is a blank page (but I can't right click or anything).


ReplyQuote
Tharindu
(@tharindu)
Admin
Joined: 4 years  ago
Posts: 120
09/07/2018 1:28 am  

Did you run that command and saw ufw active?

Become a vpsfix.com affiliate and earn up to 10% commissions from your referrals


ReplyQuote
laszlo
(@laszlo)
Customer
Joined: 3 months  ago
Posts: 23
09/07/2018 1:31 am  

I tried putting ipadresss:10000 in a firefox browser instead of chrome, and I got this :

Error - Document follows

This web server is running in SSL mode. Try the URL private-DNS-of-ec2-instance:10000 instead.

and that link leads (see image attached)

 

 


ReplyQuote
Page 1 / 2 Next
Share:
Close
  
Working

Please Login or Register