Notifications
Clear all

[Solved] Qtum wallet install error on Ubuntu 16.04 x64bit

1 Posts
1 Users
0 Likes
63 Views
Tharindu
(@tharindu)
Reputable Member Admin
Joined: 9 years ago
Posts: 307
Topic starter  

I was trying to upgrade my Qtum wallet installed on Ubuntu 16.04 x64bit server. I use this VPS for staking. I tried to upgrade the wallet with a git pull and I ran into errors during the make command.

This was the error I saw on CLI,
CXX qtum/libbitcoin_server_a-storageresults.o
qtum/storageresults.cpp: In member function ‘bool StorageResults::readResult(const h256&, std::vector<TransactionReceiptInfo>&)’:
qtum/storageresults.cpp:121:130: error: ‘NoInformation’ is not a member of ‘dev::eth::TransactionException’
1 ? static_cast<dev::eth::TransactionException>(tris.excepted[j]) : dev::eth::T
^
Makefile:9510: recipe for target 'qtum/libbitcoin_server_a-storageresults.o' failed
make[2]: [qtum/libbitcoin_server_a-storageresults.o] Error 1
make[2]: Leaving directory '/root/qtum/src'
Makefile:13716: recipe for target 'all-recursive' failed
make[1]:
[all-recursive] Error 1
make[1]: Leaving directory '/root/qtum/src'
Makefile:694: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

after investigating about this error online for a while, I realized that this is a common issue on new installs and upgrade for wallet version 0.14.15. Lots of folks reported this on github and developers had responded. You can fix this by running following command,

git submodule update

Source: #508


   
Quote
Share:
Back to top button